Info about Visual studio Debug

Jan 28, 2016 at 10:17 AM
HI I'm new to 2sxc,I start to work with 2sexy content for create some samples module for my client. Very interesting, but I have a problem.
Normaly I open the template in visual studio, I attach the debug and all work, but I can't watch the variable content, on the Razor output it work but during the debug it's impossible, I immagine because they are dynamic can you help me?

Thanks Fabio
Jan 29, 2016 at 12:18 PM
news?
Feb 2, 2016 at 2:56 PM
Edited Feb 16, 2016 at 2:01 PM
Is there any one that explain me how to debug?
thanks
Fabio
Feb 16, 2016 at 2:02 PM
Help!
Coordinator
Feb 24, 2016 at 10:47 AM
It can be done fairly well -
  1. you need a running dnn with your app / view / template inside it
  2. you need to make sure debugging is enabled in the web.config
  3. in your visual studio with the razor, attach it to the web server process (ctrl alt P) - it's usually the w3... or the iis, depending on your dev setup
That should do it.
Feb 24, 2016 at 12:48 PM
HI thanks for your reply, but I don't understand?

How can I : running dnn with your app / view / template inside it

Normally I install DNN on my local pc on my www.mywebsite.local domain
I install 2 sexy content module.
I open the template in Vsual studio (only the template) and I attach my proces to w3... process
So the debug run but the variable value isn't show on watch area

I don't understand, I need to install the source code?

Thanks Fabio
Developer
Feb 24, 2016 at 1:17 PM
You need to open the Web folder as website. Choose File > Open > Website and select the folder where your DNN installation resides in. Then open the template (the files should appear in the Solution Explorer window) and set the breakpoint. Now you should be able to attach the process to w3wp.exe and debug the template.
Feb 24, 2016 at 1:36 PM
@raphael_m

OH wow..... I don't know this.....
I try asap thanks thanks a lot

Fabio
Mar 4, 2016 at 11:17 AM
@raphael

I have tried but It don't work
Image

Hallways "internal error in the evaluation"

Can Any one help me?

Thanks
Fabio
Developer
Mar 4, 2016 at 12:40 PM
It looks like you are able to debug the template correctly (the breakpoint stops) but somehow Visual Studio seems not to be able to display the value for the variable. I'm not sure but I think this is a Visual Studio problem, not related specifically to Razor templates or the 2sxc module.
Mar 4, 2016 at 12:43 PM
I think it's very strange I use Visual studio all the day an I haven't problem.
Also for create module in the same site and problem are only with 2sexy......

But I need to install the 2sexy source code?

thanks

Fabio