2sxc v8 - Pipeline Editing cannot be opened (Missing portalroot from URL message)

Nov 6, 2015 at 10:49 AM
Hi there,

I have a DNN Install Version 7.4.1
Just installed the latest 2sxc v8.01 I believe.

I now wanted to explore CSV and created a new Pipeline (named CSV).
When clicking on the Name (CSV), it should get me to the PipelineEditor I guess.
A new window (tab) opens and immediately the following alert pops up:
"Required parameter (portalroot) missing from url - cannot continue"

Here is the URL that pops up in a new tab:

I do not know what to do, I've checked with fiddler but no success or clue, why that happens.

If anyone had similar problems, please give advise.

Nov 6, 2015 at 6:49 PM
I'm experiencing the same thing on DNN v7.4.2 & 2sxc v 8.0.2
Nov 7, 2015 at 1:26 PM
Yesterday I tried to repair by reinstalling over the same version with no success.
Nov 10, 2015 at 4:02 PM
Just did a complete uninstall and reinstall of 2sxc on our development VM.
Badly, the same message appears.
Nov 27, 2015 at 4:55 PM
I'm having the same error, multiple versions of DNN7 (both platform and Evoq), and trying 2sxc v 8.0.5. and 8.0.6 Any ideas what is the possible root cause of this?
Dec 1, 2015 at 7:25 AM
getting the same issue here

latest version on a 734 install

Dec 1, 2015 at 7:57 PM
Same for me. Fresh install of 2SXC 8.0.6 with DNN 7.4.2.

Dec 2, 2015 at 3:44 PM
Thx. Have it already as issue in github - sohuld be fixed next week - https://github.com/2sic/2sxc/issues/480
Dec 22, 2015 at 3:18 PM
Dec 23, 2015 at 12:59 PM
You're actually missing quite a few parameters. Here's a valid call:


And yours is much shorter, like

What could be the cause? These parameters are added to a JSON in the original DNN-page and then passed from button to the App-UI, and again to the designer UI. Something must be missing in this chain, unique to your situation. Let's try to corner it.
  1. Do you have the JSON in your page source (your normal DNN-page which has a 2sxc module) - it should look a bit like this:

<!-- Start_Module_421 --><div id="dnn_ctr421_ModuleContent" data-2sxc-globals="{&quot;ModuleContext&quot;:{&quot;PortalId&quot;:0,&quot;TabId&quot;:680,&quot;ModuleId&quot;:421,&quot;AppId&quot;:2},&quot;FullUrl&quot;:&quot;http://2sexycontent.2dm.2sic/en/Blog&quot;,&quot;PortalRoot&quot;:&quot;http://2sexycontent.2dm.2sic/en/&quot;,&quot;DefaultLanguageID&quot;:null}" data-2sxc="{&quot;moduleId&quot;:421,&quot;manage&quot;:{&quot;isEditMode&quot;:true,&quot;templateChooserVisible&quot;:false,&quot;hasContent&quot;:true,&quot;isContentApp&quot;:true,&quot;zoneId&quot;:2,&quot;appId&quot;:2,&quot;isList&quot;:false,&quot;templateId&quot;:3770,&quot;contentTypeId&quot;:&quot;e2351b42-87f2-427e-9566-ff271e3e5a9f&quot;,&quot;config&quot;:{&quot;portalId&quot;:0,&quot;tabId&quot;:680,&quot;moduleId&quot;:421,&quot;contentGroupId&quot;:&quot;c238e78b-a6e5-4811-a5c9-51d5ebf48b39&quot;,&quot;dialogUrl&quot;:&quot;http://2sexycontent.2dm.2sic/en/Blog&quot;,&quot;returnUrl&quot;:&quot;/en/Blog&quot;,&quot;appPath&quot;:&quot;/Portals/0/2sxc/Content/&quot;,&quot;cultureDimension&quot;:null,&quot;isList&quot;:false},&quot;applicationRoot&quot;:&quot;/&quot;,&quot;lang&quot;:&quot;en-us&quot;,&quot;langPrimary&quot;:&quot;en-us&quot;,&quot;languages&quot;:[]}}" class="DNNModuleContent Mod2sxcC">
Then these should be passed to the app-admin-dialog which is actually running in an iframe. You may have trouble viewing these, but I'm sure you'll manage. Check if the parameters you are missing exist there. I'm guessing they are already gone, but I'm not sure.

can you get me feedback?
Dec 28, 2015 at 8:38 AM
Some magic happend :)
I viewed the source and decoded / made the json readable and found those parameters.
Then I decided to just try open the pipeline editor, and you know what? It worked.
Must have been some dnn cache issue...

Thanks for your help tho, appreciate.