Cannot delete (or hide) items in a list nor in the admin.

Jan 26, 2016 at 7:36 PM
Every time I try to hide an item on a list or just simply delete it from the admin area I get a 404 telling the "No HTTP resource was found that matches the request URI 'http://DOMAIN.com/DesktopModules/2sxc/API/view/Module/RemoveFromList'."

Fiddlers is not telling me much more.
Has anyone else ran into this issue?
Any help would be greatly appreciated.
Coordinator
Jan 27, 2016 at 6:13 AM
I believe you're the second person to report this. Could you give more specs as to the versions of dnn/2sxc?
Coordinator
Jan 27, 2016 at 6:36 AM
I also tried to reproduce it but couldn't. I have a guess, but will have to check.

Could you give more specs also what App and what view this was, or if it's something you made, if the data shown was "added" to the module or if it was in data-mode (delivered through a query / pipeline or razor accessing App.Data["..."]
Jan 27, 2016 at 2:46 PM
I have 2sxc 8.0.11
And Evoq Content 8.3.0
I am using the data-mode.
I created my own app, but it's basically like the example of a news app. I pretty much copied step by step and added a few requirements from the client.
I had previous versions of both, DNN and 2sxc. I was asked to upgrade both because of other issues. So I did, looks like a lot of the issues are gone but I still have this one.

Let me know if you need anything else.
Thanks for taking the time to take a look.
Coordinator
Jan 28, 2016 at 9:53 AM
I have a guess. Could you watch the traffic in fiddler to see if it's really this call which causes a 404, or if it is redirected first (301/302) to another address, which then causes the 404?
Jan 28, 2016 at 1:22 PM
If I go into the app admin and try to delete a content item I get a HTTP 500, no 3XX before it.

If I click on the interface button Toolbar.Remove it gives me a HTTP 404, no 3XX before it.

Any other guesses?

Let me know if you want any log files, screen shots, etc.
Coordinator
Jan 28, 2016 at 1:56 PM
Sounds like you get the 500 because it's still in use, teh other one I'm not sure. Pls check the exact server message in fiddler, this is probably related to https://github.com/2sic/2sxc/issues/610
Jan 28, 2016 at 2:22 PM
Here is what Fiddler gives me:
Json: {"Message":"No HTTP resource was found that matches the request URI 'http://nmm.lswebdev.com/DesktopModules/2sxc/API/view/Module/RemoveFromList'.","MessageDetail":"No action was found on the controller 'Module' that matches the request."}
Here is the raw request:
GET http://nmm.lswebdev.com/DesktopModules/2sxc/API/view/Module/RemoveFromList HTTP/1.1
Host: nmm.lswebdev.com
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Accept: application/json, text/plain, */*
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
ModuleId: 1566
TabId: 122
RequestVerificationToken: isQfoUZdnqTschN6yRr4tycNXEhSFhfo_U2EYoxUsxJd2yDWGcWw5KnN8MV7H-RiMXNwOTCEYn_nD7sw0
Debugging-Hint: bootstrapped by 2sxc4ng
Cache-Control: no-cache
Pragma: no-cache
Referer: http://nmm.lswebdev.com/News
Cookie: .ASPXANONYMOUS=AQ-w1N2M01z87bpaBvFrMlLSD84_pi0QKCybZ27vYyohOrrh6N11HCZdZTGjV4_NmHRyXDDJlw9Qmby6fWqw1TrvpT2n0druXK3FrTwzj4X27ptd0; Analytics_VisitorId=6c1ba6f1-23f7-4da4-9163-8f077f7e3d6f; dnn_IsMobile=False; language=en-US; __RequestVerificationToken=fxhiexjXsMtLKE0bybAxP2fjbSjrAJMTqCF3y9-1tx-m2A1CbIffvEbMtHAloMS8effioA2; USERNAME_CHANGED=; authentication=DNN; .DOTNETNUKE=44850E98D23EE5F745696DD86E2E4E3DE90BDCF7EFB8DF409D7BB5402DD05F120BB0E0CF2087623F0EBA4FD86BED1730EC9D98777D144E7BB761405B89A3BA2ADBA66E65; LastPageId=0:122; StayInEditMode=NO; Analytics=SessionId=fd5934ee-b7ee-411e-a4f8-d6908c13e992&TabId=122&ContentItemId=-1
Connection: keep-alive
Jan 28, 2016 at 3:24 PM
Coordinator
Jan 28, 2016 at 9:40 PM
I believe I figured it out and I'm working on it. Let's continue on github: https://github.com/2sic/2sxc/issues/623
Feb 1, 2016 at 8:56 PM
I have upgraded to to 8.01.02 and the problem persists.

I keep getting the same error.

Let me know if you have any other ideas.
Feb 3, 2016 at 11:00 PM
It was me that reported this earlier so I'm kind of relieved to see someone else has it (sorry regorica) Looks to be the exact same problem and it has been in a few minor versions of the module. Fiddler didn't really help any. If I can help in any way to find a solution let me know.
Feb 4, 2016 at 2:26 PM
Edited Feb 4, 2016 at 2:27 PM
Duo,

Thanks! You have no idea. I have been wrecking my brain over this.
Did you find a way for items to delete or at the very least remove them from a list?

The users on the site I am developing have been adding content and are getting ready to launch but there are 2 or 3 sample items I added in the beginning and I can't delete them.

Let me know.
Feb 4, 2016 at 8:47 PM
From memory I went into the admin area > Content/Data tab, dug into the Content Type > Records, clicked on Show Items and deleted them from there as needed. Hope this helps!
Feb 5, 2016 at 2:35 PM
So I tried that, I run into the second type of error I have been getting.

Screen shot:
http://www.evernote.com/shard/s147/sh/18f57fe2-f207-430b-8cb2-f8d8913c0947/9bb8df7cd12872cfd28ec6c5e013e9e0

HTTP 500. Not sure what to do.
Coordinator
Feb 8, 2016 at 2:33 PM
There were actually 2 issues - the first was a bug and fixed in https://github.com/2sic/2sxc/issues/623 - so it'll be released in 08.01.03 - and the other 500 is usually the error when an item is still in use, so it can't be deleted.
Feb 19, 2016 at 10:52 PM
I have an update on this that may help you guys figure out what is going on.

Turns out I can delete items. I just can't delete items that were existent before I upgraded to the newest version.

Any ideas?

At this point I am almost ok with going to the DB and clearing these old items and starting fresh.
Any one have a good Sql script that I can add an entity ID and get rid of the record?