Error when upgrading to version 8

Jan 11, 2016 at 7:29 PM

I am not sure where the best place to post these issues are. I have also posted in the ISSUES tab. Sorry for the double post.

I have a DNN 7.4 platform running in ms azure. Whenever I try to upgrade the version 7 to version 8 I get the following error:
SQL Execution resulted in following Exceptions: System.Data.SqlClient.SqlException (0x80131904): Cannot insert the value NULL into column 'ContextInfo', table 'Krisis-ca-prod.dbo.ToSIC_EAV_ContextInfo'; column does not allow nulls. INSERT fails. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady) at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async, Int32 timeout, Boolean asyncWrite) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at DotNetNuke.Data.SqlDataProvider.ExecuteScriptInternal(String connectionString, String script) ClientConnectionId:bb30cb9d-4004-4078-be77-ddd77b399268 Error Number:515,State:2,Class:16 ClientConnectionId before routing:7de07a8c-b248-4426-9b54-eafed7c4539a Routing,11088 -- make sure sql rolls back automatically in case of error. SET XACT_ABORT ON BEGIN TRANSACTION SexyContentUpdate; EXEC ToSIC_EAV_ChangeLogAdd 'System' -- Create new AssignmentObjectType for Apps UPDATE ToSIC_EAV_AssignmentObjectTypes SET Name = N'Entity', Description = N'For Permissions, Data Pipelines with Pipeline Parts and Configurations' WHERE (AssignmentObjectTypeID = 4) -- Commit the transaction COMMIT TRANSACTION SexyContentUpdate; --ROLLBACK TRANSACTION SexyContentUpdate;
I have also found that when I try to edit any "item" from the content module of 2sxc I also ge the same error.

Can someone help me to track down what is happening here.

Jan 12, 2016 at 1:23 AM
for further detail this happens during the 7.0.3 sql provider
Start Sql execution: 07.00.03.SqlDataProvider file
Failure SQL Execution resulted in following Exceptions: System.Data.SqlClient.SqlException (0x80131904): Cannot insert the value NULL into column 'ContextInfo', table 'Krisis-ca-prod.dbo.ToSIC_EAV_ContextInfo'; column does not allow nulls. INSERT fails
Jan 12, 2016 at 9:26 AM
My guess it's changes in azure sql, we've had similar issues before. Pls check
  1. what version of azure sql are you using - it probably used to be 12, now it' probably 14
  2. what version of 2sxc 8 are you installing - the newest 08.00.12 should have everything fixed for the newest azure
Jan 12, 2016 at 2:27 PM
Thanks for the followup,

As this is open source and you are not "making money" I appreciate the time you take to create and support this solution.

Yes the SQL Azure db version is 14. I have tried to install the 8.0.12 package and the exact same error occurs. I am pretty sure it happens in the call:
EXEC ToSIC_EAV_ChangeLogAdd 'System'
Inside the 7.0.3 sql data provider. I am digging into it to see what is going on but the sql procedure is trying to add a value to the ToSIC_EAV_ContextInfo table where the context info column is null.

Jan 13, 2016 at 6:58 AM
Jan 13, 2016 at 2:27 PM
thanks a lot

will follow and add info there