Need Help / Exception after Installation

Dec 15, 2014 at 8:46 PM
Edited Dec 15, 2014 at 8:47 PM
Today i installed latest Release of 2SC to my DNN-Installation.

After adding module to a page i get an Exception:

ModuleId:629

ModuleDefId:139

FriendlyName:Content

ModuleControlSource:DesktopModules/ToSIC_SexyContent/View.ascx

AssemblyVersion:7.3.4

PortalID:0

PortalName:LordMM

UserID:1

UserName:LordMM

ActiveTabID:228

ActiveTabName:2SC

RawURL:/de-de/2sc.aspx

AbsoluteURL:/Default.aspx

AbsoluteURLReferrer:http://lordmm.de/de-de/home.aspx

UserAgent:Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; Touch; MAFSJS; rv:11.0) like Gecko

DefaultDataProvider:DotNetNuke.Data.SqlDataProvider, DotNetNuke

ExceptionGUID:5f98099b-9e38-4016-ad9b-eaefebd92aa2

InnerException:Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

FileName:

FileLineNumber:0

FileColumnNumber:0

Method:System.Reflection.RuntimeModule.GetTypes

StackTrace:

Message:

DotNetNuke.Services.Exceptions.ModuleLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information. ---> System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
at System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)
at System.Reflection.RuntimeModule.GetTypes()
at System.Reflection.Assembly.GetTypes()
at System.Data.EntityUtil.GetTypesSpecial(Assembly assembly)
at System.Data.Metadata.Edm.ObjectItemAttributeAssemblyLoader.LoadTypesFromAssembly()
at System.Data.Metadata.Edm.ObjectItemAssemblyLoader.Load()
at System.Data.Metadata.Edm.ObjectItemAttributeAssemblyLoader.Load()
at System.Data.Metadata.Edm.AssemblyCache.LoadAssembly(Assembly assembly, Boolean loadReferencedAssemblies, ObjectItemLoadingSessionData loadingData)
at System.Data.Metadata.Edm.AssemblyCache.LoadAssembly(Assembly assembly, Boolean loadReferencedAssemblies, KnownAssembliesSet knownAssemblies, EdmItemCollection edmItemCollection, Action1 logLoadMessage, Object& loaderCookie, Dictionary2& typesInLoading, List1& errors)
at System.Data.Metadata.Edm.ObjectItemCollection.LoadAssemblyFromCache(ObjectItemCollection objectItemCollection, Assembly assembly, Boolean loadReferencedAssemblies, EdmItemCollection edmItemCollection, Action
1 logLoadMessage)
at System.Data.Metadata.Edm.ObjectItemCollection.ImplicitLoadAssemblyForType(Type type, EdmItemCollection edmItemCollection)
at System.Data.Metadata.Edm.MetadataWorkspace.ImplicitLoadAssemblyForType(Type type, Assembly callingAssembly)
at System.Data.Objects.ObjectContext.GetTypeUsage(Type entityCLRType)
at System.Data.Objects.ObjectContext.GetEntitySetForNameAndType(String entitySetName, Type entityCLRType, String exceptionParameterName)
at System.Data.Objects.ObjectContext.CreateObjectSet[TEntity](String entitySetName)
at ToSic.SexyContent.SexyContentContextBase.get_ContentGroupItems()
at ToSic.SexyContent.SexyContentContext.get_ContentGroupItems()
at ToSic.SexyContent.SexyContentContext.GetContentGroupItems(Int32 ContentGroupID)
at ToSic.SexyContent.SexyContent.GetViewDataSource(Int32 moduleId, Boolean showDrafts, Boolean includeEditingData, Nullable1 overrideTemplateId)
at ToSic.SexyContent.SexyContent.GetContentElements(Int32 ModuleID, String LanguageName, Nullable
1 ContentGroupID, Int32 PortalId, Boolean showDrafts, Boolean isEditMode)
at ToSic.SexyContent.SexyControlEditBase.get_Elements()
at ToSic.SexyContent.SexyControlEditBase.get_Template()
at ToSic.SexyContent.SexyControlEditBase.get_IsList()
at ToSic.SexyContent.SexyViewContentOrApp.get_ModuleActions()
--- End of inner exception stack trace ---


SystemInfo:

Betriebssystemversion: Microsoft Windows NT 6.1.7601 Service Pack 1
Webserver-Version: Microsoft-IIS/7.5
Version des .NET-Frameworks: 4.0.30319.18063
ASP.Net-Identität: IIS APPPOOL\72884971

DatabaseInfo:

Datenbankversion: 11.0.5058.0
Service-Pack: SP2
Produkt-Ausgabe: Web Edition (64-bit)
Software-Plattform: Microsoft SQL Server 2012 - 11.0.5058.0 (X64)


How can i find out whats wrong ?

Jürgen
Coordinator
Dec 17, 2014 at 8:29 AM
Hi Jürgen

It's a bit tricky, but based on your stack I'm assuming you're having a problem with the Entity Framework. I'm assuming this is not an empty portal but something that has other stuff as welly. Do you have multiple versions of EF installed, or do you have other modules that used EF?
Dec 17, 2014 at 5:25 PM
Hi,

today i installed a complete new instance of latest Release of DNN.
After thist i only installed module 2sexycontent.

I got same errormessage so it seems the error is not in my other installation.

My dnn is hostet on a ASP.Net Shared Hosting Provider … so i didn’t know what is installed on the webserver.

In DNN /bin Folder there are no Libraries for EF.
The DNN-Setup comes without any EF-Libraries. The 2SC-Module also doesn’t install such Librariers.

Which version of EF does 2SC-Module need to work ?
Could i copy these Libraries die /bin-Folder ?

Regards

Jürgen

Von: [email removed]
Gesendet: ‎Mittwoch‎, ‎17‎. ‎Dezember‎ ‎2014 ‎10‎:‎29
An: [email removed]

From: 2sicDev

Hi Jürgen

It's a bit tricky, but based on your stack I'm assuming you're having a problem with the Entity Framework. I'm assuming this is not an empty portal but something that has other stuff as welly. Do you have multiple versions of EF installed, or do you have other modules that used EF?
Dec 17, 2014 at 8:32 PM
Hi,

meanwhile i tried same installation on another hosting provider.
Everthing works fine there. No Errors anymore.

Thanks for your help.

I’ll now open a support ticket for my other server.

Jürgen

Von: [email removed]
Gesendet: ‎Mittwoch‎, ‎17‎. ‎Dezember‎ ‎2014 ‎10‎:‎29
An: [email removed]

From: 2sicDev

Hi Jürgen

It's a bit tricky, but based on your stack I'm assuming you're having a problem with the Entity Framework. I'm assuming this is not an empty portal but something that has other stuff as welly. Do you have multiple versions of EF installed, or do you have other modules that used EF?
Coordinator
Dec 18, 2014 at 7:36 AM
Found the problem :)

It's a DNN issue with Multilanguage. The DNN version you're using has a infamous bug.

Raphael will post the details in a few minutes.
Developer
Dec 18, 2014 at 8:06 AM
Jürgen, I think Daniel posted this into the wrong discussion :)

But the error you had seems to be caused by a EntityFramework version issue. There might be others being affected.

Please update this thread as soon as you get an answer from the hosting provider.

Raphael
Dec 18, 2014 at 4:30 PM
Hallo Rapael,

meanwhile i installed dnn 7.3.4 on another hosting provider. After this i tested the module on this server. Everything works without any problems.

I think you are right. The server at my current hosting provider have any problem.
I will open a ticket there ... or even better ... i use the new hosting provider ;-)

Thanks a lot.

Regards Jürgen