Setting up entity field

Nov 26, 2014 at 4:30 PM
I have created a content type called "Reports", in which I have an entity field to select the category for each report that will be entered.

I have set up another content type called "Reports categories", which contains one string field, "Category". I have entered 3 categories into this field. I have "Category" set in the EntityType in the entity field in Reports.

However, when I add a new entry into Reports, nothing populates into the Category entity field. I have watched every video I can find on entities and still can't figure out what I'm doing wrong.

Nov 26, 2014 at 8:17 PM
So just to understand you scenario :
  • report categories has 2-3 entities (like products, revenues, etc. )
  • report has an entity field which should show these three categories to select from
Because from you description, I think this is where you got stuck. You should create multiple category-entities to choose from in the categories. Not multiple lines in one text field, but multiple entities.

Hope this helped :)
Nov 26, 2014 at 8:53 PM
Hi amanda

You could take a look at my blog at i have a simple news app described rhere as well as demo download

You can check tjat out and you will see what daniel means

Apr 30, 2015 at 3:56 PM
Edited Apr 30, 2015 at 3:56 PM
I am having trouble with this yet again. I wish I could remember what I did differently last time I set up a content type like this, when I finally figured it out!

Nokiko, in the sample app you sent me, I changed the name of the e_team content type to e_dept. I reflected this change in the entity settings for its field in the person content type as well. I had added 6 departments to the dept content type, but nothing shows up in the dropdown list of the entity field linked to it when I try to add a person.

Entity field settings:

Content types:

Person content type data structure:
Apr 30, 2015 at 4:05 PM
Hi Amanda

I see in the first screenshot you have still e_team

so on your person content

for department click the entity link and then change the entity type to e_dept

that "should" do it.
Apr 30, 2015 at 4:21 PM
I forgot to mention I had tried changing that content type name back to e_team. The entity field is also set to e_team.
Apr 30, 2015 at 4:33 PM
can you export the app so I can check for you
Apr 30, 2015 at 5:05 PM
Apr 30, 2015 at 5:56 PM
hi Amanda

It looks ok to me i do see the dropdown when I import the app and add a new person

the reason you dont see any items is yo forgot to change something in the code you ahve a reference still set to e_dept that you need to change to e_team
allItems.TypeName = "e_team";
Apr 30, 2015 at 6:02 PM
I took a break from this to work on something else for a while, came back to it, and now it's working. Go figure!
Apr 30, 2015 at 6:06 PM
Nevermind... I added 2 people, then went to add a third person, and now no teams are being shown.
Apr 30, 2015 at 7:21 PM
Did you modify the razor code as i mentioned as well

Verstuurd vanaf mijn iPad

Op 30 apr. 2015 om 19:06 heeft amandathomas <[email removed]> het volgende geschreven:

From: amandathomas

Nevermind... I added 2 people, then went to add a third person, and now no teams are being shown.
Apr 30, 2015 at 7:58 PM
I did, but I just thought that affected the template.

I just got back from lunch, and so far have been able to add 5 new people and select their teams successfully. I don't understand how I fixed it but okay. :)

Thanks for all your help!