Entity Framework added to 6.04.00 ToSIC_ SexyContent web.config

Nov 5, 2014 at 3:37 PM
When I upgraded to 6.04.00 from 6.03.06, all of my 2sxc modules disappeared and showed an error that Entity Framework was already referenced. I am using Entity Framework in one of my custom modules, so I already have it in my DNN web.config.

It looks like Entity Framework was added in the 2sxc 06.04.00 module web.config, and was causing the issue. I commented out the 2sxc config for Entity Framework, which fixed the issue, but I was wondering if this was an intended part of the update... Does 2sxc use Entity Framework?
Coordinator
Nov 11, 2014 at 1:01 PM
Yes, it uses EF, I believe the standard version in the referenced .net framework.