Microsoft.CSharp.RuntimeBinder.RuntimeBinderException with BlueImp App

Oct 14, 2014 at 5:37 PM
Hi,
I just tested the last version 6.3.4 on DNN 7.3.3. I have two languages on this test portal.
All apps seems to work well except BlueImp Gallery. As soon as I try to select gallery setting, the system block with following message.
Any idea to correct this?
Thanks in advance, Dom

AssemblyVersion:7.3.3

RawURL:/aboutus/testdom4.aspx

AbsoluteURL:/Default.aspx

AbsoluteURLReferrer:

UserAgent:Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko

DefaultDataProvider:DotNetNuke.Data.SqlDataProvider, DotNetNuke

ExceptionGUID:6ee625ed-78f1-4777-91fe-0f32e2c9ee09

InnerException:Cannot perform runtime binding on a null reference

FileName:

FileLineNumber:0

FileColumnNumber:0

Method:N/A - Reflection Permission required

StackTrace:

Message:

Microsoft.CSharp.RuntimeBinder.RuntimeBinderException: Cannot perform runtime binding on a null reference
at CallSite.Target(Closure , CallSite , Object )
at System.Dynamic.UpdateDelegates.UpdateAndExecute1[T0,TRet](CallSite site, T0 arg0)
at ASP._Page_Portals_0_2sxc_Content__GalleryHelpers_cshtml.get_Folder() in e:\Websites\Newdesign3\Portals\0\2sxc\Content_GalleryHelpers.cshtml:line 21
at CallSite.Target(Closure , CallSite , Object )
at System.Dynamic.UpdateDelegates.UpdateAndExecute1[T0,TRet](CallSite site, T0 arg0)
at ASP._Page_Portals_0_2sxc_Content__Gallery_cshtml.Execute() in e:\Websites\Newdesign3\Portals\0\2sxc\Content_Gallery.cshtml:line 22
at System.Web.WebPages.WebPageBase.ExecutePageHierarchy()
at System.Web.WebPages.WebPageBase.ExecutePageHierarchy(WebPageContext pageContext, TextWriter writer, WebPageRenderingBase startPage)
at ToSic.SexyContent.Engines.RazorEngine.RenderTemplate()
at ToSic.SexyContent.Engines.EngineBase.Render()
at ToSic.SexyContent.View.ProcessView()
Coordinator
Oct 14, 2014 at 8:28 PM
a bit strange. Did you change something, or is your line 21 also this:
                var basePath = (string)App.Settings.BasePath;
did it work before (with 6.3.3) or could you test if it does?

Thanks,
Daniel
Oct 14, 2014 at 9:48 PM
No I didn't change anything. I cleaned dnn from all 2sxc elements, installation works well.
I just tested the 6.3.4 with my production site still remaining under DNN 7.3.2 but exactly the same problem.
And yesterday I tested 6.3.3 on DNN 7.3.3 with exactly the same problem.
Tomorrow, I will try it on a clean DNN installation.
Thanks for your help,
Dom
Oct 14, 2014 at 10:11 PM
I just make a test with another site on another server.
It was in DNN 7.0.2. I upgraded to DNN 7.3.3
Then installed 2sxc 6.3.4 and same error message...
Coordinator
Oct 15, 2014 at 7:55 AM
this is odd. Any other clues? like are you on azure or on a windows server? what version? what .net version?
Oct 15, 2014 at 10:41 AM
I'm Joelle and I work with ddelforge
We're on Windows Server. With DNN 7.3.3.

Let's see the way we try to install BlueImp Gallery.
We have created a page with 2sexyContent and we want to use BlueImp Gallery :
Image

So we use the "Get more apps..." option
choose the right file to upload : 2sxcApp_blueimpGallery_01.00.03.zip
but we get this two messages :
The import has been done. View messages below for more information. (Toggle Success Messages)

Could not import the package. Import not allowed because the specified folder does already exist.
Image
Coordinator
Oct 15, 2014 at 12:38 PM
this is because in portals/2sxc/apps/blueimp... already exists. This happens if you install an app, remove 2sxc and reinstall. just remove manually.
Oct 15, 2014 at 3:40 PM
Thanks for your response.
I desinstall 2sxc extension, App extension and after that remove manually /DesktopModules/ToSIC_SexyContent and /Portals. i remove also /Portals/Default/2sxc.
And I resinstall both 2sxc extension and App extension.
unfortunaltly when I try to install by "Get more apps..." option, I still have the same errot message : "Could not import the package. Import not allowed because the specified folder does already exist."

So I try to install 2sxcApp_blueimpGalleryforList_01.00.00.zip
It does work fine;
but when I want to upload (or drag ans drop) an image I get :
Image
Coordinator
Oct 15, 2014 at 4:05 PM
Hi JoelleSK

I'm guessing it has something to do with existing folder - but the easiest way would be if we could quickly log unto your system w/host permissions. Would that be ok? send it to info@2sxc.org.

Best,
Daniel
Oct 15, 2014 at 4:16 PM
Edited Oct 15, 2014 at 4:16 PM
Hello
you should not use blueimpGalleryforList_01.00.00.zip. at the moment.

I'll delete the so called blueimpGalleryforList_01.00.00.zip here in this dicussion board . It's not very well tested at the moment, and I've probably made some mistakes which eventually could cause issues. To be concret, I've not created a new app. Instead i've simple changed the original 2sic-blueimp-app and export the new result. Maybe there are some App-guid conflicts or other conflicts when installing both of them.

Collective
Coordinator
Oct 16, 2014 at 9:01 AM
@Collective
Thanks for your input

@Joelle: did you use the blueim from 2sxc.org/apps or the one Collective created?
Coordinator
Oct 16, 2014 at 9:44 AM
@Joelle: I'm just looking into your portal

You're not using our bluimp gallery, but the one @Collective modified... As he said this is not production grade but experimental

I just installed it but can't install our newest blueimp - I think the folder isn't removed. Do you know why I can't see the "2sxc" folder in your root? there are lots of folders there with numbers, but I can't spot 2sxc
Coordinator
Oct 16, 2014 at 9:46 AM
Did you maybe delete the 2sxc folder?
Coordinator
Oct 16, 2014 at 9:52 AM
Would it be ok if I completely re-install 2sxc? I assume you don't have data in it yet...but I could be wrong.
Oct 16, 2014 at 11:10 AM
Yes ok no problem. This is a test site.
Coordinator
Oct 16, 2014 at 12:14 PM
It seems to be a bug in the DNN URL-Provider. The version you're using is old (from V5 or V6) and has a bug delivering the wrong upload-URL to the JavaScript.

The best solution is to change to the new URL-Provider, that should fix everything.

Look for "HumanFriendly" in the web.config and change that to "advanced"

Best,
Daniel
Oct 16, 2014 at 5:20 PM
Yes!
It works.
Thanks for your help Daniel. Great support!
Dom
Coordinator
Oct 17, 2014 at 12:15 PM
You're welcome.
And please rate us! Ratings helps build trust for new users. Rate us on the dnn-store. To rate it in the store, just buy it for free first.
By this you are helping us spread the word and motivate us :)

Thanks & Love from Switzerland
Daniel, Raphael and Benjamin
2sic and 2sxc